VectorLinux
November 24, 2014, 02:30:56 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: CUPS  (Read 1880 times)
nightflier
Administrator
Vectorian
*****
Posts: 4029



« on: March 30, 2009, 06:36:24 pm »

Package cups seems to have gone missing. If I do a google search there are several hits for it in /patches, but upon closer inspection it is not there. My glsapt can't find it either.
Logged
Chris H
Member
*
Posts: 29


« Reply #1 on: March 30, 2009, 10:23:42 pm »

It's in mine!

1.3.9-i586-2vl60
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #2 on: March 31, 2009, 04:34:00 am »

Chris, are you showing cups installed, or available from the repo? Test this by clicking the square and see if the "re-install" option is available.
Logged
StrayBit
Vectorite
***
Posts: 373



« Reply #3 on: March 31, 2009, 07:49:22 am »

I just made sure all five repositories (incl testing and gsp) at osuosl were selected.  I have it installed but nothing showing as latest version
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
Chris H
Member
*
Posts: 29


« Reply #4 on: March 31, 2009, 11:58:36 am »

Chris, are you showing cups installed, or available from the repo? Test this by clicking the square and see if the "re-install" option is available.

Good point! No reinstall available.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3192



« Reply #5 on: March 31, 2009, 12:04:25 pm »

And might I add that the currently isntalled package produces a HTTP 404 error when trying to access http://localhost:631

I've gone around and around trying to find a fix for this, but nothing so far.

Maybe a rebuilt/newer version would fix this.
Logged

nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #6 on: March 31, 2009, 05:04:01 pm »

@M0E-lnx: Add line to /etc/cups/cupsd.conf:
Code:
DocumentRoot /usr/doc/cups
Restart cups and try again.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3192



« Reply #7 on: March 31, 2009, 05:38:42 pm »

WoW!... Thanks nightflier...

This has been hanging on the back of my head for months.

I actually had the line on there, I found that reference on a www search some time ago, but I guess it was the wrong syntax. I had it like this
Code:
DocumentRoot = /usr/doc/cups
which does not work..

Thanks for the fix.
Logged

Lyn
Vectorian
****
Posts: 652



« Reply #8 on: March 31, 2009, 11:08:17 pm »

No go still get 404 not found message.

I pasted the line in the the config file as below


# Administrator user group...
SystemGroup sys root
DocumentRoot /usr/doc/cups
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!