Please support VectorLinux!

Author Topic: Tuxtype 2 package  (Read 2788 times)

tbrown

  • Member
  • *
  • Posts: 15
Tuxtype 2 package
« on: April 01, 2009, 07:15:18 am »
I am interested in helping provide a reliable TuxType2 package for Vector Linux 5.9 STD and 6.0 STD. I have tried packages from Slackware and SlackBuilds and have compiled TuxType2. All but one have failed.

I even tried TuxType v1.0.3; it won't install due to a dependency issue. I might be a bug in the TuxType2 code since the Slackware package at the TuxType web site installs and the code runs then segfaults.

What confuses me is I have TuxType2  (tuxtype2-1.5.3-i386-1) working on one - and only one - VL 5.9 STD installation. I have tried other 5.9 installs (fresh and patched) and failed. For the life of me, I can't recall what I did differently, if anything, on this particular machine regarding TuxType.

I am willing to put time in to solve the problem, whatever it is, so people who want to learn to type have at least one package available for multiple languages. Test beds are not a problem. I have access to an a large supply of used computers.

Tom

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Tuxtype 2 package
« Reply #1 on: April 02, 2009, 02:09:01 pm »
I'll have a look at it sometime in the next few days if I get time. However, there is already a typing tutor in the repos - which should be multilingual as well. Have a look for klavaro (its in extra for Vl6.0, and I think I built it for Vl5.9 as well). The version for VL6.0 is here:

ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-6.0/extra/x-apps/klavaro-1.1.8-i586-1vl60.tlz

paul.

tbrown

  • Member
  • *
  • Posts: 15
Re: Tuxtype 2 package
« Reply #2 on: April 08, 2009, 09:19:28 am »
Thanks for the Klavaro tip. I installed it on my VL 5.9 Std box. Klavaro seems thorough although less engaging than Tuxtype. The two packages together make a good combination.

Tom

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Tuxtype 2 package
« Reply #3 on: April 12, 2009, 09:33:17 am »
Thanks for the Klavaro tip. I installed it on my VL 5.9 Std box. Klavaro seems thorough although less engaging than Tuxtype. The two packages together make a good combination.

Tom

:) Well, there's an update to klavaro, and I've built Tuxtype2 for both VL5.9 and 6.0. Both run on my laptop without problems. Only problem is that at present, I can't move them into the repo - something strange happening with permissions.

I did look at building 1.0.3, but there's an annoying error in the install routine which I was too lazy to try and fix....

Keep an eye out in the announcements area - I'll post as soon as I can get packages moving into the repo again.

paul.