VectorLinux
December 20, 2014, 10:32:51 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How do you terminate X windows?  (Read 1361 times)
frank56
Member
*
Posts: 30


« on: April 08, 2009, 04:48:02 pm »

From VASMCC I get a message "This program cannot be used when X terminal is running. Please terminate X-windows first. How do I terminate X-window? I have thunar running.. Frank
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: April 08, 2009, 05:09:03 pm »

You can terminate x by calling a run-level that does not use it.
Open a terminal and us su to become a root user.
Enter 'init 3' without the quotes.
You will see the runlevel you are in shut-down and the new one will start up.

No x means no gui so be prepared to work in text mode.
You will have to sign in as user first. Then just type 'vasm' again without the quotes. Then choose super from the list. This should get you back to the choices you had when using VasmCC
What program are you trying to run.?
Ken

Here is a little more on init and runlevels...
http://www.opensourcebistro.com/Tutorial/VL60/terminal/init/run-levels.htm
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
overthere
Vectorian
****
Posts: 1281



« Reply #2 on: April 08, 2009, 05:25:58 pm »

you may also access tui or text user interface during boot by useing the down arrow to highlight tui and hit enter..if the gui is not working you still have access..I think hardware config in vasm requires text mode

cheers
Logged

Everything Is Relative
Pita
Vectorian
****
Posts: 1319


« Reply #3 on: April 08, 2009, 05:29:59 pm »

To get out of X I do:

Ctrl-Alt-F1 in my case, may be F2 or F3 for others.
This brings you on a console.
Login as root
Do your vasm
Logout
Then
Alt-F7
and you are back in your X

Regards
Logged
frank56
Member
*
Posts: 30


« Reply #4 on: April 08, 2009, 06:55:53 pm »

Thanks! Everyone for the tips. Initially I tried Pitas ...Control Alt..+ F1, that just gave me a Blue screen and HOPE. So I tried Contro + Alt + F2. That worked great. Control Alt F7 got me back "windows". Now I will be able to access some settings I could not do before. Thanks again everyone. Frank
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!