Author Topic: solved problem with a soundcard (Creative Soundblaster Live)  (Read 3252 times)


  • Member
  • *
  • Posts: 2
solved problem with a soundcard (Creative Soundblaster Live)
« on: April 07, 2009, 01:32:34 pm »
Hello there,
just installed Vector Linux light 6.0 and I love it, right from the very first moment.
Thanks to the developers and all people, working on it.
But there is always the great "but".

On my machine, built in 2001, there is a Creative Soundblaster Live, which didn`t work with this new VectorLinux.

Opening alsamixer within xterm, i could see the name of the soundchip, name of the soundcard and all known settings.
Trying to listen to an internet stream in xterm with mpg123 was only possible as "root".

Well, i found a solution at the homepage of Patrick Volkerding and his slackwarelinux. I hope, it is a help to others having similar
problems in getting sound:

Distribution FAQ of Slackware Linux

Q: I loaded the driver for my sound card, but I can only play sounds as root. How can I let all users play sounds?

The easiest way is to open up the permissions on /dev/dsp* and /dev/mixer* to all users:
chmod 666 /dev/dsp*
chmod 666 /dev/mixer*


  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: solved problem with a soundcard (Creative Soundblaster Live)
« Reply #1 on: April 07, 2009, 08:13:05 pm »
Was your user part of the audio group? If so, I wouldn't think you'd need to change permissions because /dev/dsp and /dev/mixer give read write permissions to users in the audio group.

I don't remember how this option is presented in Light when you're setting up a user. When I set myself up as user, I always check all the boxes.
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller


  • Member
  • *
  • Posts: 2
Re: solved problem with a soundcard (Creative Soundblaster Live)
« Reply #2 on: April 08, 2009, 12:42:57 pm »
Yes, there was the ability to check after "adduser" the groups and rights
for the new one, the audio group too.

I repeated the installation today without that "bring it on mate, I can`t wait" in my mind, watching every step of configuration.
Now everything is just fine but I`m still asking myself, what went wrong in getting sound yesterday.

Today, I had a problem with my network card, I saw the module "dmfe" in the "System Profiler and Benchmark" loaded, but a /sbin/ifconfig showed no network card at all and there was no internet.

I saw during the installion and final configuration, that my card was recognized with "dmfe" as driver. So I opened   VASM , NETWORK, INET
and started the network by a mouseclick.