VectorLinux
July 23, 2014, 10:11:53 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Webcam (Logitech E3500) - works and doesn't work - see below  (Read 3246 times)
swarfendor437
Member
*
Posts: 21


« on: April 05, 2009, 06:15:52 am »

Hi peeps,
Webcam Application works but Cheese! doesn't - do I need to remove Webcam application for Cheese! to work? (Works fine on DreamLinux 3.5 rc4 and final). Tried unplugging the usb connection out and back in again but no joy - aMSN works. Just Cheese! is the problem.

Best regards,
swarfendor437
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2276


« Reply #1 on: April 05, 2009, 06:42:42 am »

I just tested it and it doesnt work here also, it just stays there without image.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #2 on: April 05, 2009, 07:40:48 am »

Hi:
Think I have a solution for you.  It has to do with V4L1 compatibility.
See tutorial.
http://www.opensourcebistro.com/Tutorial/VL60/06.Accessories/Cheese/cheese-fix.htm

PS, just made it in response to your question, thanks for the idea.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
swarfendor437
Member
*
Posts: 21


« Reply #3 on: April 05, 2009, 08:48:55 am »

Hi stretchedthin,
Nice touch with the tutorial - what is the software you used for this? is it from the bistro website? Very nice touch!

Will give it a try when logged in to daughter's machine. Thanks again!

swarfendor437

PS how are you with wireless? http://forum.vectorlinux.com/index.php?topic=9239.0
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #4 on: April 05, 2009, 04:36:06 pm »

Hi swarfendor437;

I just got home from work.  You should know that before the tutorial I posted will work you have to download libv4l-0.5.8 from sourceforge.net and run make, make install on it.  I already had installed it because that's how I fixed a similar problem with skype video.  Sorry, I shouldn't try to rush an answer in before going to work.

I use Wink to create the video's, pretty easy to use.  There is some links on where to get it and how-to's on it at www.opensourcebistro.com

I'm going to fix the tutorial with the additional data, so you may want to check it in about an hour. (same link)

I'll also take a look at your wireless question, but it's not my strength.
Ken
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
swarfendor437
Member
*
Posts: 21


« Reply #5 on: April 06, 2009, 01:42:41 am »

Hi stretchedthin,

Follolwed your wink tutorial and I still get zilch sadly! The program runs but I get a Test Card transmission similar to what the BBC used to do back in the 1960's!
Yesterday paid for 'Deluxe' download - think I made a mistake as I wanted the version with MegaMario in it - is it on SOHO?

Best regards,
swarfendor437 Wink
« Last Edit: April 06, 2009, 02:19:30 am by swarfendor437 » Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #6 on: April 06, 2009, 07:31:57 am »

Hi swarfendor437
Don't know about megamario, but maybe I can look at how hard it is to install from source for you.  I know it's on sourceforge.net.

Just to check up on the 'cheese' problem. 
Did you download and install libv4l-0.5.8.tar.gz ?
To test, type or copy this into the terminal.
      export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so (press enter)
then type
     cheese (press enter)
Did you get any type of error output in the terminal?  Could you post it here if you did?
or When cheese starts do you get any better result this way?
stretchedthin


Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
swarfendor437
Member
*
Posts: 21


« Reply #7 on: April 07, 2009, 07:53:04 am »

Hi stretchedthin,
Thought I would try your instructions on the Standard (free) download of VL6.0 and I get this in the terminal after I copied the bit after installing v4l1.0:

"cheese: error while loading shared libraries: libv4l1.so.0: cannot open shared object file: No such file or directory"

Any ideas?

Best regards,
swarfendor437 Wink

PS with regards to Mario - know it was present on some of the earlier Vector releases, just surprised I could not find it on CD or repos - downloaded from Sourceforge.net - it downloads as non-platform specific for Win and Linux - just click on the .exe in Vector after extracting files and it runs just fine! (Tried it on my windows rig and it froze!)
« Last Edit: April 07, 2009, 07:55:17 am by swarfendor437 » Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #8 on: April 07, 2009, 10:23:20 am »

"cheese: error while loading shared libraries: libv4l1.so.0: cannot open shared object file: No such file or directory"

Any ideas?

PS with regards to Mario - know it was present on some of the earlier Vector releases, just surprised I could not find it on CD or repos - downloaded from Sourceforge.net - it downloads as non-platform specific for Win and Linux - just click on the .exe in Vector after extracting files and it runs just fine! (Tried it on my windows rig and it froze!)

For the cheese error.
I think you may just need to reboot the system after installing the libv4l.
Sorry to put you through this, but thanks for being my tester on this tutorial. 

Do you plan to use skype as well?  To use skype video required the same steps. If you get cheese working
you will probably be able to get skype video to work as well.

http://www.opensourcebistro.com/Tutorial/VL60/11.Network-apps/skype/skype.htm

So Mario worked from an exe file, did you run it through wine.  Glad you got it going.
Ken
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
swarfendor437
Member
*
Posts: 21


« Reply #9 on: April 08, 2009, 02:49:28 am »

Hi stretchedthin,
Yes I do intend installing Skype. Will check if the reboot works/ed regarding v4l. Thanks for your patience.

Best regards,
swarfendor437

PS On Standard I could copy the .exe onto the desktop and it worked fine - not so on deluxe. On Standard it 'automatically' linked the .exe to wine without the context menu!
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #10 on: April 08, 2009, 08:18:25 pm »

[quote author=swarfendor437 link=topic=9240.msg61642#msg61642 PS On Standard I could copy the .exe onto the desktop and it worked fine - not so on deluxe. On Standard it 'automatically' linked the .exe to wine without the context menu!
[/quote]

Do you mean that when you copied the .exe file to the Desktop it didn't work they way it deid on Standard? Or couldn't you copy the file at all?

I just copied an EXE file in Thunar from a FAT32 partition to the Desktop. I simply highlighted the EXE file on the FAT32 partition, selected Copy, and then opened the Desktop directory in Thunar and selected Paste. I did not attempt to run it.

Ordinarily, EXE files do *not* work in Linux. You have to open them with Wine. If your EXE file is launching in VL without the assistance of Wine, there must be something peculiar about that perticular EXE.

I'm using VL6 Standard, Deluxe edition. Next question: are you sure you have Wine installed? It is not preinstalled in either Standard or Deluxe. You need to install it through Gslapt.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
swarfendor437
Member
*
Posts: 21


« Reply #11 on: April 10, 2009, 01:06:12 am »

Hi GrannyGeek,

Sorry about this - going off topic - please ignore the stuff about .exe - I think because I had installed wine it was auto associating with it.

Hi stretchedthin,
Back to the webcam issue: Still no joy with cheese but you will be surprised to learn that skype ran out of the box after install with no problem.
Nor is there a problem with aMSN apart from being unable to install the Snack files to enable sound!

regards,
swarfendor437
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #12 on: April 10, 2009, 08:17:47 am »

Swarfendor437;

Sorry about cheese, we gave it a good shot.  Will your daughter be ok with WxCam (Webcam Application.)?
Anyway, lots of people here smarter than me, if you want to keep pursuing it.

Thanks for the idea about megamario, I added a tutorial about it to my site.

Enjoy the weekend.
stretchedthin
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!