VectorLinux
August 28, 2014, 12:57:42 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 090405 lyx-1.6.2 [VL5.9]  (Read 1075 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: April 05, 2009, 06:52:13 am »

hata_ph has built lyx for VL 5.9 

Package: yx-1.6.2-i586-1vl59.tlz
MD5: 1c5bd62ea5827be9904a96e177ca179c
Package Size: 7086 K
Installed Size: 38340 K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/lyx

Code:
lyx: lyx (The Document Processor)
lyx:
lyx: LyX is a document processor that encourages an approach to
lyx: writing based on the structure of your documents (WYSIWYM),
lyx: and not simply their appearance (WYSIWYG).
lyx:
lyx:
lyx:
lyx: License: GPL2
lyx: Authors: The Lyx Team
lyx: Website: http://www.lyx.org

After testing this package please stop back here and let us know how it works for you.

Logged
sledgehammer
Vectorian
****
Posts: 1421



« Reply #1 on: April 13, 2009, 05:35:18 pm »

I believe hata_ph has also kindly built lyx-1.6.2 for VL6.0.  In any event, it is in the VL6.0 testing repository.  I have a couple of comments.  I don't know how, but I somehow got qt4.5 loaded.  I may have been in the testing repository when I loaded qt4 (required by lyx) or the lyx-1.6.2 download may have automatically loaded qt4.5.(Error was that Lyx couldn't find one of the qt4 libraries).  In any event, I had to downgrade to qt4.4.1 (in the regular repositories) before lyx-1.6.2 would run. 

I don't know if I needed to do this or not, but I also downloaded python when lyx wouldn't work.  The lyx.org site says phthon is necessary. Lyx.org also says that lyx requires Texlive or tetex (tetex is in the repositories), so I downloaded that too.  Neither fixed the problem (downgrading to qt4-4.4.1 fixed the problem I was having).

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #2 on: April 26, 2009, 08:45:45 am »

I am not sure what go wrong when you install lyx-1.6.2 but from lyx-1.6.2 slack-required it require qt4.3.2. I don't use lyx so I am not sure about it. Maybe other that install lyx-1.6.2 for VL5.9 can give comment about it.

Quote
aiksaurus >= 1.2.1-i586-3vl59
aspell >= 0.60.5-i486-2
cxxlibs >= 6.0.8-i486-4 | gcc-g++ >= 4.1.2-i486-1
expat >= 2.0.1-i486-1
fontconfig >= 2.4.2-i486-2
freetype >= 2.3.7-i586-1vl59
gcc >= 4.1.2-i486-1
glib2 >= 2.12.13-i486-1
glibc-solibs >= 2.5-i486-5
libICE >= 1.0.4-i486-1
libSM >= 1.0.3-i486-1
libX11 >= 1.1.3-i486-1
libXau >= 1.0.3-i486-1
libXcursor >= 1.1.9-i486-1
libXdmcp >= 1.0.2-i486-1
libXext >= 1.0.3-i486-1
libXfixes >= 4.0.3-i486-1
libXi >= 1.1.3-i486-1
libXinerama >= 1.0.2-i486-1
libXrandr >= 1.2.2-i486-1
libXrender >= 0.9.4-i486-1
libpng >= 1.2.29-i586-1vl59
libxcb >= 1.0-i486-2
qt4 >= 4.3.2-i586-1vl59
zlib >= 1.2.3-i486-2

About pythoin and tex support, I believe python come with VL5.9 as default. It may not be correct cause I am using VL6 most of the time which python do come as default too. For Tex, it is not a must have requirement dependency for lyx. I do ask about whether to include tetex or latex as lyx dependency and some suggest not to.

Hi, there.

To add tetex to the slack-required you can set the ADD variable before requiredbuilder like this:

Code:
echo "Finding dependencies..."
ADD="tetex >= 3.0" requiredbuilder -v -y -s $RELEASEDIR $PKG
echo "Creating package $NAME-$VERSION-$ARCH-$BUILD.tlz"
makepkg -l y -c n $RELEASEDIR/$NAME-$VERSION-$ARCH-$BUILD.tlz

I'm not sure about putting tetex as a dependency, though. The reason being that tetex is only one possible latex distribution (I'm using lyx with texlive).

I'm not sure about what's best though. I think it might be best to leave it without the dependency, because you can inadvertently forget to uncheck tetex for install, and end up with downloading and installing tetex, when you already have some other latex distribution in your machine. On the other hand, if you just install lyx, it wouldn't work because you need latex. But then again, you would know that you need latex if you want lyx, I guess.

Yea, I guess not putting a particular latex as dependency is best... I think the only reason tetex is the only one in the repo is that the whole texlive is massive in terms of size.

http://forum.vectorlinux.com/index.php?topic=6720.15
http://www.lyx.org/AdditionalSoftware

Maybe in the next release of lyx that i can package i better mention that it does not include tex package and you need to install it manually. Tongue
« Last Edit: April 26, 2009, 09:20:30 am by hata_ph » Logged
sledgehammer
Vectorian
****
Posts: 1421



« Reply #3 on: April 28, 2009, 10:16:49 pm »

Never crossed my mind that lyx might not need latex or tetex. I have never tried lyx without.  Until I figured out that I had the wrong version of qt4 loaded, I probably "fixed" a lot of things that were not broken.  If lyx comes out with a later version, and you compile it for vector, I will pay more attention.

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #4 on: April 29, 2009, 02:29:22 am »

I try install latex or tetex (what ever package that i can find in the repo) before compile lyx in VL5.9 before but in the slack-required the latex or tetex package is not listed there. I will try again when the new version is out. Tongue
Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #5 on: April 29, 2009, 03:09:36 am »

I couldn't install tetex nor latex (they're not in the repos, or at least, I coudldn't find them)

I used http://www.tug.org/texlive/acquire.html tl-install package, and did a 'TeX Live installation over the Internet' .

I don't use lyx, but latex through my usual editor of choice, and it's working ok.

Logged

hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #6 on: April 29, 2009, 08:30:30 am »

tetex 3.0 is available in VL repo for VL5.9 and 6.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!