VectorLinux
December 20, 2014, 04:45:21 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 915resolution - can't download  (Read 4024 times)
yakrider
Member
*
Posts: 6



« on: April 07, 2009, 06:34:07 am »

Hi, all

New to VL - must say 6.0 looks and feels good!

I'm installing on a Fujitsu-Siemens Lifebook laptop, which has a very nice LCD screen for an older machine. Laptop uses the Intel 82852/855GM chipset.
My screen runs comfortably at 1400 x 1050 (4:3) in Ubuntu and XP, however Vl is only using 2/3 of the screen - very odd. The rest of the screen is "black", although backlit.
I added the 1400 x 1050 resolution to xorg.conf, but this has no effect.

Searching the forum suggests to me I need to install 915resolution. Is this correct?
One thing, though, Gslapt or slapt-get can't find it. I have the standard sources provided by install and I have successfully upgraded the installation.

Any pointers, please?
Logged

ThankQ and regards,
nightflier
Administrator
Vectorian
*****
Posts: 4038



« Reply #1 on: April 07, 2009, 06:43:27 am »

With the newer Intel driver you don't need 915 resolution. What driver is specified in your xorg.conf file?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #2 on: April 07, 2009, 06:54:07 am »

Which video driver are you using?
I used to need 915 resolution, but it's been a long time since I had to use it.

Find out which driver you are using from your /etc/X11/xorg.conf

At any rate. I have just built and uploaded 915resolution.
It should make it to the "testing" area of the repos soon. Maybe later today
Logged

yakrider
Member
*
Posts: 6



« Reply #3 on: April 07, 2009, 08:40:01 am »

Thanks for speedy reply, guys

@nightflier + @M0E-lnx

Quote
Find out which driver you are using from your /etc/X11/xorg.conf
This one:
Driver   
Quote
  "intel"
VendorName  "Intel Corporation"
BoardName   "82852/855GM Integrated Graphics Device"

I know there's nothing wrong with the screen because I popped a live Ubuntu CD in and it boots to 1400 x 1050, using the entire screen.
I have to go out for a couple hours - back at 9:45pm SAST. Please let me know if you require further info.
Logged

ThankQ and regards,
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #4 on: April 07, 2009, 08:59:40 am »

Well, it's hard to say which driver you're using with that output.
but if it is the intel driver, you'll need to change that to make it use either the i915 or i810

I dont think 915resolution will do anything with the intel driver, IIRC, you have to use the i915. but the i810 should also be fine.
Logged

yakrider
Member
*
Posts: 6



« Reply #5 on: April 07, 2009, 12:39:22 pm »

Here is the complete xorg.conf
I bolded the "Driver" line - it's using Intel
Gslapt shows "xf86-video-i810" is installed (not i915 - which Gslapt also can't find)
Do I simply replace "Intel" with "i810" on the Driver line?

BTW, I added the "1400 x 1050" resolution below.
Quote
Section "ServerLayout"
Identifier     "X.org Configured"
InputDevice    "Synaptics Touchpad"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/share/X11/rgb"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load  "glx"
Load  "extmod"
Load  "xtrap"
Load  "record"
Load  "dri"
Load  "GLcore"
Load  "dbe"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  ""    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/input/mice"
Option       "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
 Identifier    "Synaptics Touchpad"
 Driver        "synaptics"
 Option        "SendCoreEvents"    "true"
 Option        "Device"            "/dev/psaux"
 Option        "Protocol"          "auto-dev"
 Option        "SHMconfig"         "true"
 Option        "HorizScrollDelta"  "0"
 Option        "VertEdgeScroll"  "1"
 Option        "TapButton1"  "1"
EndSection

Section "Monitor"
Option "DPMS"
DisplaySize 381 238 # 96 DPI @ 1440x900
Option "UseEdidFreqs" "1"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 31.5-64
VertRefresh 40-90
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [
arg]: arg optional
#Option     "NoAccel"               # [<bool>]
#Option     "SWcursor"              # [<bool>]
#Option     "ColorKey"              #
#Option     "CacheLines"            #
#Option     "Dac6Bit"               # [
<bool>]
#Option     "DRI"                   # [<bool>]
#Option     "NoDDC"                 # [<bool>]
#Option     "ShowCache"             # [<bool>]
#Option     "XvMCSurfaces"          #
#Option     "PageFlip"              # [
<bool>]
Identifier  "Card0"
Driver      "intel"
VendorName  "Intel Corporation"
BoardName   "82852/855GM Integrated Graphics Device"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1400x1050" "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

Logged

ThankQ and regards,
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #6 on: April 07, 2009, 12:44:44 pm »

IIRC, the i915 module is part of the xf86-video-intel package.

I have already uploaded the 915resolution package... it should make it to the repos soon.

You can try 915 resolution with all 3 drivers and see if any of them give you better results.
Logged

yakrider
Member
*
Posts: 6



« Reply #7 on: April 08, 2009, 05:13:32 am »

@M0E-lnx

I have installed the 915resolution package.
I then booted into linux-tui, ran vasm>xwindow.
On reboot I get a black screen. Not really knowing the outcome, I changed this line in xorg.conf:
Driver "intel" to Driver 915resolution.
The xserver would not start, as I suspected, because I'm shooting in the dark.
Can you please tell what to do, perhaps?
Logged

ThankQ and regards,
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #8 on: April 08, 2009, 05:35:54 am »

NO... No... No....

915resolution will not work as your "Driver"... it is not a driver...

You see, 915resolution is a BIOS Hacking program.
You will need to use the "intel" or "i810" driver still. You will just have to use 915resolution to hack it so it gives your the correct resolution.
this hack will have to be applied every time you reboot (we'll get this automated once we find out what works).

Here is what I need you to do.
open a terminal window.
su to root
show me the output of
Code:
915resolution -l
Logged

yakrider
Member
*
Posts: 6



« Reply #9 on: April 08, 2009, 05:55:26 am »

oops, here id the output:
Quote
# 915resolution -l
Intel 800/900 Series VBIOS Hack : version 0.5.3

Chipset: 855GM
BIOS: TYPE 2
Mode Table Offset: $C0000 + $3c3
Mode Table Entries: 21

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 36 : 1024x600, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 47 : 1024x600, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 56 : 1024x600, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
Logged

ThankQ and regards,
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #10 on: April 08, 2009, 06:42:44 am »

Since the video mode you want is not listed, you'll have to override one of the available options.

This may take some serious trial-and-error testing to see which one works for you.

here is what you do...
Print out that list, because you will need to drop down to text mode for this.

open a terminal
su to root
Code:
init 3
This will drop you down to text only.
I would say you can start with mode 4b, 4d, 5a, and 5c.

if none of those work, you can try any other ones close to the ones I listed for you.
The way you do it is...at the prompt.. loged in as root, you execute this command.
Code:
915resolution <mode_id> <horiz_size> <vert_size> <color_depth>
so.... for example... to set your mode 4b, you would do.
Code:
915resolution 4b 1400 1050 32

After that, you want to start the gui to see if it works or not.
you can simply issue
Code:
startx
if it doesn't work, just press CTRL+ALT+BackSpace to exit the GUI and go back to text mode.
Try another method...
repeat until you find the one that works.

Remember, for this to work, your "Driver" line in /etc/X11/xorg.conf must be set to either "intel" or "i810"

Once you find the one combination that works, post back and I'll tell you how to automagically make it work every time you start the computer.

You can find more info at this guide
http://www.geocities.com/stomljen/readme.html
« Last Edit: April 08, 2009, 06:47:16 am by M0E-lnx » Logged

yakrider
Member
*
Posts: 6



« Reply #11 on: April 08, 2009, 12:50:09 pm »

@M0E-lnx

I tried most of the modes - none worked. In fact the installation started to hiccup after repeated CTRL+ALT+BackSpace sequences.
I needed to do a bit of work, so installed Xubuntu (which installed out of the box into 1400 x 1050)

I'll give VL a bash again soonish. The strange thing is how Vl only used 2/3 of the screen - not full screen with big resolution. You've gone to a lot of trouble to help me which I appreciate, but may I take a rain check?
Logged

ThankQ and regards,
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!