VectorLinux
August 29, 2014, 12:04:33 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Setting keyboard to non-US  (Read 1191 times)
pme127
Member
*
Posts: 3


« on: April 08, 2009, 06:15:31 am »

Keyboard map will not leave the US. When I select UK I am invited to test my UK keyboard, but it is still typing as US.

I suspect you know this, but don't how to fix it. VL (Lt) looks promissing, but needs to fix the keyboard bug.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #1 on: April 08, 2009, 07:00:57 am »

in a terminal (DO NOT RUN THIS AS ROOT)
Code:
setxkbmap -layout gb
Logged

pme127
Member
*
Posts: 3


« Reply #2 on: April 08, 2009, 10:25:39 am »

in a terminal (DO NOT RUN THIS AS ROOT)
Code:
setxkbmap -layout gb

Thanks, I was in root because I thought settings in root applied to all users unless changed by a user in their own account (I may be wrong), and I wanted a UK keyboard system wide.

In my user account I entered setxkbmap -layout gb in a terminal, and it worked, but reverted to US on reboot.

The same thing happens in Absolute Linux, which has many similarities with VL, including the keyboard problem, there has been much disucssion in AL forums over the last year or so, to no avail, the GU keyboard configuration doesn't work.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4022



« Reply #3 on: April 08, 2009, 11:21:12 am »

You say this is in VL6 Light? Which window manager/desktop environment are you using?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #4 on: April 08, 2009, 12:00:46 pm »

Yes... this is a per-session setting.
If you want a global setting you need to modify your /etc/X11/xorg.conf and find the line that says
Code:
Option "XkbLayout" "us"
and change that "us" to a "gb"
Logged

pme127
Member
*
Posts: 3


« Reply #5 on: April 09, 2009, 03:41:31 am »

I am running VL6 Light as a Guest in VirtualBox 1.5 running on Windows XP SP2, with several other Linux and Windows guests, and the default/revert to US keyboard problem is confined to Linux.

nightflier
You say this is in VL6 Light? Which window manager/desktop environment are you using?

I don't know, how can I find out. At install I opted for defaults or lightest/fastest option.

Yes... this is a per-session setting.
If you want a global setting you need to modify your /etc/X11/xorg.conf and find the line that says
Code:
Option "XkbLayout" "us"
and change that "us" to a "gb"

I have loged on as root and peter opened a terminal, gone: cd /, ls -a, cd etc, ls -a. I can't find /X11/xorg.conf anywhere, perhaps there is another /etc?

PS As I am on a virtual hard disk (VHD), which I have backed up at clean install and again at each successfull configuration step, working in root is not a problem, though I only do so when neccersary.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!