VectorLinux
August 01, 2014, 01:44:27 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Need volume control in taskbar at startup  (Read 979 times)
TLM
Member
*
Posts: 88


« on: April 08, 2009, 07:31:42 pm »

This is probably really easy, however I am still fairly new to Linux. Currently running SOHO 5.9 Deluxe with KDE desktop. I would like for the volume control to be in the taskbar by the clock. I have used other distros where the volume is there on startup, and all I had to do was place my cursor over it and run the mouse wheel to adjust the volume. As of right now, I have to open Kmix, and then adjust the volume that way. If I pin the Kmix shortcut from the start menu to the panel, it does not function as a volume control; I still have to click on it and open Kmix. I did go to the Kmix Settings page and checked the box that says "dock into panel" and "autostart" however that did not seem to do anything. Also, is there a networking icon I can place in my panel to let me know the status of my LAN connection? Thanks for any and all input. May the Redmond Bulldozer feel the mighty Penguin Push!! Smiley
Logged

Particle board should be outlawed.
kukibl
Guest
« Reply #1 on: April 11, 2009, 05:47:17 am »

Probably your session is not being saved on logout. Open KDE Control Center > KDE Components > Session Manager and check On Login - Restore previous session. Then run kmix, log out and login again, it should be present...

Otherwise, you could i.e. add kmix.sh file to ~/.kde/Autostart.

Open your favourite editor, enter next code and save it as kmix.sh in your home folder:

Code:
#!/bin/sh
/usr/bin/kmix &

Then make it executable and move it like this:

Code:
$chmod +x kmix.sh
$mv kmix.sh ~/.kde/Autostart/

That should solve your problem.

About networking icon... In Slackware there is knemo - network monitor. If it is not available in VL repo, you could request it or maybe use Slackware package. Otherwise, you could use wicd to manage and monitor your network connections.
« Last Edit: April 11, 2009, 05:49:28 am by kukibl » Logged
TLM
Member
*
Posts: 88


« Reply #2 on: April 11, 2009, 10:21:41 am »

Thanks! I will try the steps you suggested.
Logged

Particle board should be outlawed.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!