VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Multi-boot query  (Read 975 times)

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Multi-boot query
« on: April 04, 2009, 04:17:51 pm »

I have a dual boot XP/VL5.9 setup that works fine. When I installed 5.9, I let LILO write to the MBR, so I have a single boot menu with XP and 5.9 as the options.

I now want to add VL6.0 to this, using the "install from within Linux" method.

Rather than do it then post a question when I get in a mess, I thought I'd  try to head off trouble at the pass for a change  ;).

To be safe, I plan to tell the install procedure NOT to let LILO write to the MBR (so it will write instead to the new partition that gets created during the install process).

Q1) if I do this, when I reboot, will I get my old menu (with no new 6.0 option, of course) or will I  get 6.0 starting up automatically, with XP and 5.9 now inaccessible?

Q2) since I already have a Linux Swap partition defined for 5.9, am I right that I can  reuse this for 6.0 as well  ?
 
Thanks
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: Multi-boot query
« Reply #1 on: April 05, 2009, 06:17:26 pm »

You could edit your lilo.conf file to include VL 6.0 in the LILO boot menu. I think you would have to tell the 6.0 installer to not install LILO and on reboot I believe the LILO boot menu would appear and you would have to edit the lilo.conf file (/etc/lilo.conf) from VL 5.9. Also, yes, the swap partition can be reused for 6.0.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Re: Multi-boot query
« Reply #2 on: April 06, 2009, 02:19:17 am »

Thanks for the reply  ;D.

Quote
you would have to tell the 6.0 installer to not install LILO

I didn't know you could do that..will try it and see.

Quote
the swap partition can be reused for 6.0.

That will save space  :D. I thought that, since I plan to install from VL5.9, that would mean the swap partition was "in use" which might flag it as out of bounds for the new install. Will try that too.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4140
Re: Multi-boot query
« Reply #3 on: April 06, 2009, 07:18:19 am »

After running the install and skipping LILO, boot to 5.9 and run "vliloconf". It should pick up your new VL partition and add it to the boot menu.
Logged

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Re: Multi-boot query SOLVED
« Reply #4 on: April 09, 2009, 03:26:32 pm »

success  ;D

I used the Lilo SKIP option and then manually edited lilo.conf once back in 5.9.
 
Now, if I can only get my LAN card working in 6.0   ;)
Logged