VectorLinux
April 24, 2014, 11:53:39 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Chestnut connection is slow.  (Read 4073 times)
arundracula
Member
*
Posts: 57


« on: April 10, 2009, 08:45:20 pm »

I am using chestnut-dialer in VL 6.0 STD GOLD.
In 5.8 SOHO, I used kppp to connect to the internet and in fedora/kubuntu I used wvdial to connect.
But in VL6.0, the connection speed is lower than that of VL5.8/fedora/kubuntu.
Is there anyway to increase the internet speed?
Can we use wvdial instead of chestnut(if the problem is within chestnut)? If yes, which are the additional packages I have to install?

These are the main settings of my connection.

IP, DNS - Dynamic
Authentication PAP/CHAP
No Terminal Authentication
device - /dev/ttyACM0
Connection speed - 115200
Flow control - hardware
Line Termination -CR/LF

What is the maximum transmission and receive unit? What if we change those? (Default 296)
Logged

Re-installing is not a problem, but it is when I had to.
overthere
Vectorian
****
Posts: 1224



« Reply #1 on: April 10, 2009, 09:23:08 pm »

try lowering the connestion speed a little and see if that helps..

cheers
« Last Edit: April 10, 2009, 09:26:46 pm by overthere » Logged

Everything Is Relative
arundracula
Member
*
Posts: 57


« Reply #2 on: April 11, 2009, 01:15:21 am »

ok. I'll try.
Logged

Re-installing is not a problem, but it is when I had to.
overthere
Vectorian
****
Posts: 1224



« Reply #3 on: April 11, 2009, 01:56:20 am »

It may not help your situation but with some modems you are periodically disconnected or experience slow connection speed and lowering the dialers connection speed can solve or reduce this..my us robotics external will only hold a connection at 14.4 but does function at higher speeds with periodic disconnection.

it is possible that kppp is included with kde I am not sure and although wvdial is not in my gslapt list it may be in testing..otherwise it may be downloaded and compiled manually..be sure to check for dependancies if aquireing from outside sources.I have not used either.

cheers
« Last Edit: April 11, 2009, 01:58:42 am by overthere » Logged

Everything Is Relative
arundracula
Member
*
Posts: 57


« Reply #4 on: April 11, 2009, 08:52:07 am »

I couldn't notice any change in increase of the speed. kppp is included in every kde distribution. But all kppps are  saying "Modem not responding" except in VL 5.8 SOHO. What are the settings Max transmission unit/Max receive unit? Will it change the speed?

I'll try wvdial manual installation. Thank you for your co-operation. I tried almost all linux versions but I couldn't find any ready-made linux like VectorLinux. All other requires a lot of some packs to install after OS installation.

Another question, can we share a folder as FTP over the internet in VL 6.0? Which pack I have to install?
Logged

Re-installing is not a problem, but it is when I had to.
overthere
Vectorian
****
Posts: 1224



« Reply #5 on: April 11, 2009, 01:18:28 pm »

the mtu and mru refer to the packet size, any messages larger than the packet size are divided into smaller packets..it can increase speed but much depends on the size of the pipe..you may try increase to 576 or play with values from 296 to 1500 depending on the available bandwidth and your modems capability. I am not sure what else to suggest..perhaps someone else has greater knowledge.

cheers
Logged

Everything Is Relative
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #6 on: April 11, 2009, 01:35:55 pm »

Another question, can we share a folder as FTP over the internet in VL 6.0? Which pack I have to install?

there is proftpd and vsftpd in the repositories. I normally use the sftp service provided by the sshd daemon, which is fine for personal use and it is secure. If you plan to share files for the world to download from your comuter, the first two are better options.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
arundracula
Member
*
Posts: 57


« Reply #7 on: April 12, 2009, 08:38:12 am »

Result of:

1) proftpd
 - notice: unable to bind to Unix domain socket at '/var/run/proftpd/test.sock': Permission denied
 - mod_tls/2.1.2: compiled using OpenSSL version 'OpenSSL 0.9.8g 19 Oct 2007' headers, but linked to OpenSSL version 'OpenSSL 0.9.8h 28 May 2008' library
 - Fatal: unable to load module 'mod_tls.c': Operation not permitted


2)vsftpd
500 OOPS: vsftpd: not configured for standalone, must be started from inetd

3)sshd
sshd re-exec requires execution with an absolute path.


How to ? Can you please calrify?
Logged

Re-installing is not a problem, but it is when I had to.
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #8 on: April 13, 2009, 07:27:47 am »

Looks like you are starting the daeons as user? You need to be root to start them. I would recommend you to read some documentation about those programms, their configuration and te implicances of running them, since they need to be configured accordingly with your needs.
What are your goals? do you want to make a file server or reach your personal files remotely? you will be accessing the service from your local network? or from the internet?
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
arundracula
Member
*
Posts: 57


« Reply #9 on: April 13, 2009, 08:44:00 am »

I run all the commands as root.(In terminal I entered su and typed root pssw then typed the commands).

Do I have to log out and log in as root or just su and password then commanding?

My need is to share a folder as ftp so my friend(s) can access the folder over internet using any FTP client software.

If you haven't much time, give me some tutorial links.
Logged

Re-installing is not a problem, but it is when I had to.
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #10 on: April 13, 2009, 11:58:32 am »

I run all the commands as root.(In terminal I entered su and typed root pssw then typed the commands).

Do I have to log out and log in as root or just su and password then commanding?

There is no need for a logout, once you enter the root password all the command since then ar executed as root, until you issue the exit command, which leaves you again in your regular account.

Quote
My need is to share a folder as ftp so my friend(s) can access the folder over internet using any FTP client software.

Ok, the reason I asked is because using an ftp server for a few personal files is a bit overkill, and you can use the sftp feature of sshd instead and keep the things simple.

Quote
If you haven't much time, give me some tutorial links.

I will have to try those in my box at home and check those error messages, not a lot of time available but we can try a few stuff Smiley
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #11 on: April 13, 2009, 02:56:13 pm »

ok, first, we have a bug in the proftpd package, I am the culprit of that one. I packaged new openssl without noticing that the new packages would break proftpd. I need to recompile proftpd against the new openssl packages. You can install this package from slackware so you dont have to wait for me:

http://slackware.osuosl.org/slackware-12.1/patches/packages/proftpd-1.3.1-i486-2_slack12.1.tgz

Open a terminal and cd into a temporary location of your choice, then:

Code:
wget  http://slackware.osuosl.org/slackware-12.1/patches/packages/proftpd-1.3.1-i486-2_slack12.1.tgz
# become root to upgrade the package
su
# upgrade the package instead install so you dont get two versions installed at the same time
upgradepkg proftpd-1.3.1-i486-2_slack12.1.tgz

Now we are ready to start playing with proftpd. There is two ways or modes for running proftpd. The first one is the StandAlone mode. proftpd will run as a daemon in the background listening from connections. The second one is the inetd mode. This one uses the inetd service for starting the proftpd process. Instead of having the daemon running all the time, the process will start only when a client asks for it at the port 21 or another port of your choice. This one has the obvious advantage of not needing the ftpd daemon running all the time. We have another daemon (yeah I know, funny) that can start or stop other daemons for us.

The StandAlone mode.

This one is more easy, you dont need to configure inetd. Open a terminal and with the text editor of your choice open /etc/proftpd.conf, for example:

Code:
vim /etc/proftpd

Then comment the inetd line, and uncomment the StandAlone one, so they look like this:

Code:
ServerType                      standalone
#ServerType                     inetd

Now we are ready for our first test, in the terminal as root run:

Code:
proftpd -n

The -n flag will prevent proftpd from detaching from the terminal to the background. This is cool for testing as you can see the logs in that terminal window and you can stop the daemon easily by hiting control+c at any time. So, with your favorite ftp client try to connect to your own box, I like lftp myself.
In the proftpd terminal I can see:

Code:
root:# proftpd -n
 - warning: the DisplayFirstChdir directive is deprecated and will be removed in a future release.  Please use the DisplayChdir directive.
vector1.baires - ProFTPD 1.3.1 (stable) (built Tue Jul 29 13:25:16 CDT 2008) standalone mode STARTUP
vector1.baires (vector1.baires[192.168.0.2]) - FTP session opened.
vector1.baires (vector1.baires[192.168.0.2]) - USER rbistolfi: Login successful.
vector1.baires (vector1.baires[192.168.0.2]) - FTP session closed.

And using lftp, I see in another terminal:

Code:
rbistolfi:$ lftp vector1.baires -u rbistolfi
Password:
lftp rbistolfi@vector1.baires:~> ls docs
drwxr-----   2 rbistolfi rbistolfi     4912 Sep 19  2008 Programming_in_Lua

That is the directory listing of my ~/docs directory (yeah, I lost my docs in my last migration, I forgot to backup them, I will have to use my google foo again to recover them). A note: at this point, only users with an account in your box can access the server, so you need to use your username and password and the same permissions policy of the regular filesystem is valid over the ftp protocol.

Allowing anonymous login.

Allowing anonymous login is easy. In the /etc/ftpusers files there is a list of users, those are the users that are NOT ALLOWED to use the ftp system. Remove the ftp user from that list to allow anonymous login. This will take the users to the /home/ftp folder after connecting, in that directory you can place files to share.
At this point you should read something about how to secure an ftp server, stay tunned with security updates and advisories on proftpd etc etc. Avoiding anonymous login is maybe a good idea. One way of doing that would be creating a user exclusively for ftp. You can add new users using vasm. You could create one user called, for example, ftp-user. Use its home directory as shared folder, give the user and the password to your trusted friends.
As time permits, I will add some information about the inetd mode of proftpd, the sftp feature of sshd, and maybe some about httpd. We could put together a nice HowTo about file sharing in VL.

HTH


Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
arundracula
Member
*
Posts: 57


« Reply #12 on: April 14, 2009, 10:31:47 pm »

This is working. Thank you. I tried with gFTP, I could enter into another account's home folder with this login. Is there anyway to share the specified folder ONLY?
Logged

Re-installing is not a problem, but it is when I had to.
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #13 on: April 15, 2009, 07:14:02 am »

As always, there is a lot of ways to do the same, but I would do this: put this line in your /etc/proftpd
Code:
DefaultRoot  ~/shared

or any directory of your choice. Be sure the directory exist. When your users login, they can't see anything on top of the DefaultRoot.
There is also more complex and advanced possibilities using some others proftpd configurations. Take a look at the proftpd userguide at http://www.proftpd.org/localsite/Userguide/linked/userguide.html
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
arundracula
Member
*
Posts: 57


« Reply #14 on: April 15, 2009, 08:53:16 am »

OK. Thank you.
Logged

Re-installing is not a problem, but it is when I had to.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!