VectorLinux
December 21, 2014, 11:26:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Computer shutting down during boot  (Read 1319 times)
awl77
Member
*
Posts: 2


« on: April 12, 2009, 01:35:06 am »

Trying to install VL Light 6.0 on a Sony Vaio PCG-F180. Shortly after the boot screen (Somewhere around the time when it begins looking for plug-and-play devices) the computer just shuts off. I have succesfully installed xubuntu on the same machine, but originally had the same problem with that dist. I was able to solve the problem with that installation according to the following post: http://www.physik.uni-freiburg.de/~zwerger/cip/Vaio/software-fix_Linux.htm

Solution for fixing the powerdown problem of Sony Vaio laptops:
This was sent to me by Florent. Thanks alot!!!:
I have probably the fix for running a VAIO without shutdown on Linux !!!
And you don't need to compile a new kernel in order to fix it.
The trick works on Mandrake 9 but it should work on any distribution :

- When you have the choice to press ENTER or F1 to install Mandrake from
the CDROM, press F1 to choose an alternate way of installation
- Type : linux *apm=off no-hlt*

Here is the trick. Disabling apm is not enough in Linux, you should also
disable the HLT instruction. This is related to cpu iddle. On any
serious distribution, you could append parameters to the kernel at boot
time so the principle will be the same on other distributions.
Then, you can install Mandrake without shutdown during the installation...
After, when you must choose and configure the boot manager (lilo or
grub), you must edit the entries in order to add the options *apm=off
no-hlt* to the kernel at boot time.

I have tried the same method with VL but for some reason it is still powering down. I suspect it is still a power issue. I am a fairly new linux user. Could anyone give me some more suggestions as to what linux boot switches I could try?
Logged
kukibl
Guest
« Reply #1 on: April 12, 2009, 02:51:02 am »

Maybe it is a stupid question, but how did you pass parameters? With or without asterisks (*)?

On lilo boot screen, you should hit <tab> key and pass:

Code:
linux apm=off no-hlt

Also, you could try with acpi=off parameter...

This is just suggestion, an idea. Except acpi=off few times, I never had to pass paramaters to boot manager.
Logged
awl77
Member
*
Posts: 2


« Reply #2 on: April 12, 2009, 03:10:04 am »

I added the acpi=off parameter and it worked! Thanks. So the the boot parameters that worked:
linux apm=off no-hlt acpi=off
This might be useful to other old laptop owners with power issues. Now I can proceed with the install.  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!