VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL 6.0 eternal boot loop  (Read 2729 times)

Stokstaartje

  • Member
  • *
  • Posts: 36
VL 6.0 eternal boot loop
« on: April 16, 2009, 06:02:03 am »

Hi,

I installed VL 6.0 on its own partition. I have 5.9 on another partition and /home on yet a third partition. I have both 6.0 and 5.9 in the boot menu with 6.0 being the default. I can boot/login fine with 5.9, which has been the workhorse for the past year(s), but 6.0 results in the following messages:

Loading VectorLinux
BIOS data check successful

Followed by the machine rebooting and showing the boot menu again.

This is all on an old Dell Latitude C600.

Any ideas on how to investigate further and/or solve this?

TIA,
Logged
----------------------------------
I hope I didn't brain my damage!

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: VL 6.0 eternal boot loop
« Reply #1 on: April 16, 2009, 06:25:25 am »

Show us the output of:

cat /etc/lilo.conf
fdisk -l
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #2 on: April 16, 2009, 07:47:59 am »

Show us the output of:

cat /etc/lilo.conf
fdisk -l


Just to rule out any confusion on my part, I can only do this when logged in via VL 5.9. Wouldn't that just show me the old lilo.conf of the 5.9 install?
Logged
----------------------------------
I hope I didn't brain my damage!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VL 6.0 eternal boot loop
« Reply #3 on: April 16, 2009, 08:18:03 am »

Mount the partition which hosts the 6.0 install and then post it's /etc/lilo.conf

fdisk -l should be the same from either side.

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #4 on: April 16, 2009, 08:49:49 am »

Mount the partition which hosts the 6.0 install and then post it's /etc/lilo.conf

fdisk -l should be the same from either side.

Ouch, that simple! sorry.... lilo.conf reads as follows:

# LILO Configuration file
# Generated by the VectorLinux installer
#
# Begin lilo global configuration
#
boot = /dev/hda
default = VectorLinux
prompt
compact
timeout = 100
#
#
# Override dangerous defaults that require the partition table:
change-rules
reset

bitmap = /boot/bitmap/boot.bmp

# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
#vga = normal
#VESA framebuffer console @ 1024 x768x64k
#vga = 791
#VESA framebuffer console @ 1024 x768x32k
#vga = 790
#VESA framebuffer console @ 1024 x768x256
#vga = 773
#VESA framebuffer console @ 800 x600x64k
#vga = 788
#VESA framebuffer console @ 800 x600x32k
#vga = 787
#VESA framebuffer console @ 800 x600x256
#vga = 771
#VESA framebuffer console @ 640 x480x64k
#vga = 785
#VESA framebuffer console @ 640 x480x32k
#vga = 784
#VESA framebuffer console @ 640 x480x256
#vga = 769
# Begin listing OS Choices

 

image = /boot/vmlinuz
root = /dev/hda1
label = VectorLinux
append = "splash=silent"
initrd = /boot/initrd
read-only


image = /boot/tamu/vmlinuz-hda3
root = /dev/hda3
label = Vector-hda3
append = "splash=silent"
initrd = /boot/tamu/initrd-hda3
read-only

+++++++++++++++++++

On the fdisk -l command, does this need to be run as root, because I get a "command not found" message as reply?
Logged
----------------------------------
I hope I didn't brain my damage!

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #5 on: April 16, 2009, 08:55:10 am »

fdisk -l, run as root gives:

root:# fdisk -l

Disk /dev/hda: 20.0 GB, 20003880960 bytes
255 heads, 63 sectors/track, 2432 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         973     7815591   83  Linux
/dev/hda2             974        1035      498015   82  Linux swap
/dev/hda3            1036        1521     3903795   83  Linux
/dev/hda4            1522        2432     7317607+  83  Linux
Logged
----------------------------------
I hope I didn't brain my damage!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VL 6.0 eternal boot loop
« Reply #6 on: April 16, 2009, 10:10:00 am »

Try this
when the LILO sreen comes up, hit the tab key, then enter this

VectorLinux root=/dev/hda1 ro vga=791 splash=verbose

See if you can catch any error messages before it loops.

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: VL 6.0 eternal boot loop
« Reply #7 on: April 16, 2009, 11:39:30 am »

I am grasping at straws here but I don't suppose you have filled up /dev/hda3 have you? It is only 4GB large and if you added other programs maybe there is not enough disk space. I could be wrong. If you mount hda3 show us what "df -h" says.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #8 on: April 16, 2009, 11:55:24 am »

Try this
when the LILO sreen comes up, hit the tab key, then enter this

VectorLinux root=/dev/hda1 ro vga=791 splash=verbose

See if you can catch any error messages before it loops.

The only message flying by fast is:

Probing EDD (edd=off to disable)...

At least that is what I think I saw flashing before the screen went black and the reboot sequence started.
Logged
----------------------------------
I hope I didn't brain my damage!

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #9 on: April 16, 2009, 12:02:22 pm »

I am grasping at straws here but I don't suppose you have filled up /dev/hda3 have you? It is only 4GB large and if you added other programs maybe there is not enough disk space. I could be wrong. If you mount hda3 show us what "df -h" says.

df -h results in:

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             3.8G  3.2G  599M  85% /
/dev/hda4             7.0G  5.8G  1.2G  83% /home
tmpfs                 123M     0  123M   0% /dev/shm
/dev/hda1             7.5G  3.4G  4.2G  45% /mnt/hda1

lilo.conf is stored on hda1.
Logged
----------------------------------
I hope I didn't brain my damage!

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL 6.0 eternal boot loop
« Reply #10 on: April 16, 2009, 05:46:07 pm »

Probing EDD (edd=off to disable)...quence started.

May be worth trying to add "edd=off" to your boot options.
Logged

Stokstaartje

  • Member
  • *
  • Posts: 36
Re: VL 6.0 eternal boot loop
« Reply #11 on: April 17, 2009, 02:15:58 am »

Probing EDD (edd=off to disable)...quence started.

May be worth trying to add "edd=off" to your boot options.

I added this option both in lilo.conf with an extra append edd=off and on the boot commandline:

VectorLinux root=/dev/hda1 ro vga=791 edd=off splash=verbose

But no luck.
Logged
----------------------------------
I hope I didn't brain my damage!