Please support VectorLinux!

Author Topic: samba fails to start, probably related to another issue  (Read 1327 times)


  • Member
  • *
  • Posts: 1
samba fails to start, probably related to another issue
« on: April 19, 2009, 04:33:36 pm »
i recently migrated my vl install from a scsi drive over to an ide drive. things seemed to go well except for a few problems:

my network card fails to start during normal startup, where it used to start just fine by itself
my glibc seemed to have gotten messed up, i could no longer compile any apps from source
my samba would not start up automatically with my rc.local script entry, but would start fine from a terminal

i created manual entries in my rc.local to start my network card config, this seemed to work just fine for me. but samba still would not start up automatically. i thought it may be because it was trying to start before the network was initialized, so i created my own samba startup script consisting of a sleep 60 command followed by samba start, just to give it ample time for the network to start up... no luck

next i used gslapt to re-install glibc, gcc, and gcc-g++. upon doing this, it broke my entire system. here's the messages i would get:
Code: [Select]
administrator:$ ls
bin/ls: relocation error: /lib/tls/ symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file with link time reference
absolutly any command thrown at a terminal would result in the same error. doing a google search, i pulled up some info on a fix for this being to rm /lib/tls/* using a boot cd. something related to a package manager not removing/moving the files in this directory. so after booting a rescue disk and removing /lib/tls/* i was able to boot back into the system, and compiling sources now works.

but now, samba will not start at all, even manually after the system boots. i get a failed, folowed by a core dumped message. here is the relevant part of the core dump:
Code: [Select]
no-process-group log-stdout Log to stdout build-options Print build options Listen on the specified ports Common samba options: loaded services
 Becoming a daemon.
 smbd version %s started.
 Changed root to %s
 waiting for a connection
 tdb_reopen_all failed.
 tdb_reopen_all failed. listen: %s
   ** sam sync message received, ignoring
 received sam replication message, serial = 0x%04x
  smb_conf_updated: Got message saying smb.conf was updated. Reloading.
  Run interactive (not a daemon)  Run daemon in foreground (for daemontools, etc.)    Don't create a new process group    Build-time configuration overrides: Copyright Andrew Tridgell and the Samba Team 1992-2006  standard input is not a socket, assuming -D option
 open_sockets_smbd: Too many sockets to bind to
 open_sockets_smbd: interface %d has NULL IP address !
  open_sockets_smbd: accept: %s
  allowable_number_of_smbd_processes: number of processes (%d) is over allowed limit (%d)
    allowable_number_of_smbd_processes: can't open connection tdb.
 allowable_number_of_smbd_processes: can't fetch INFO/total_smbds. Error %s
 uid=%d gid=%d euid=%d egid=%d
  ERROR: failed to setup guest info.
 open_sockets_smbd: listen: %s
  ERROR: Samba cannot create a SAM SID.
  Could not open account policy tdb.
 ERROR: smbd can not open secrets.tdb
   ERROR: Can't log to stdout (-S) unless daemon is in foreground (-F) or interactive (-i)

i tried searching for possible fixes for this but i really dont see where the specific cause of the error is, it seems like a lot is wrong. this core dump is identical to the dump from when samba would not start automatically during boot but would start manually after boot.

thanks in advance,