VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: GDM Login Screen  (Read 2761 times)

orloff34

  • Member
  • *
  • Posts: 8
GDM Login Screen
« on: April 23, 2009, 02:14:18 pm »

Hello,

I am using VL6.0 light with gdm as display manager. When changing language to german also the login screen is changed to german as well as the session. The session is set permantly to German whereas login screen is again in English with the next reboot/restart. Is there any configuration file to change manually to set also the login screen permantly to german?

Kind regards
Orloff34
Logged

agrismusic

  • Member
  • *
  • Posts: 4
Re: GDM Login Screen
« Reply #1 on: May 04, 2009, 02:32:04 am »

You can change your system locale and env setting and your system language will change including gdm, wdm, xfce etc. You can do it by editing the /etc/profile.d/lang.sh and lang.csh.


$ mcedit /etc/profile.d/lang.sh


comment LANG=en_US so it looks like this:

Code: [Select]
#export LANG=en_US

create new line

Code: [Select]
export LANG=de_DE

or

Code: [Select]
export LANG=de_DE.UTF-8

If you want to use unicode. Press F2 to save and F10 to exit.

Similar for lang.csh


$ mcedit /etc/profile.d/lang.csh


Find the setenv LANG en_US
comment it:
Code: [Select]
#setenv LANG en_UScreate new
Code: [Select]
setenv LANG de_DEor
Code: [Select]
setenv LANG de_DE.UTF-8for unicode.
Logged

orloff34

  • Member
  • *
  • Posts: 8
Re: GDM Login Screen
« Reply #2 on: May 05, 2009, 11:41:40 am »

Thanks a lot. It works fine with my system.

But the correct syntax for utf8 is (using locale -a in the terminal)

Code: [Select]
export LANG=de_DE.utf8
Regards
Orloff34
Logged