Please support VectorLinux!

Author Topic: Adding Icewm  (Read 1868 times)

Lyn

  • Vectorian
  • ****
  • Posts: 661
Adding Icewm
« on: April 23, 2009, 10:29:12 pm »
As regular readers will know I am fond of icewm.  However when I try to install the meta package icewmvmods on VL6 Deluxe I get the following error:

xterm: Depends: libxcb >= 1.1-i586-1vl60

If I ignore it the packages install but when I try to launch via the GDM screen it bombs out and I am returned to the GDM log on screen

Any clues?

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: Adding Icewm
« Reply #1 on: April 24, 2009, 03:24:19 am »
The package was only tested on VL Standard  :(

I have seen that unsatisfied dependency with other packages, though. Looks like Std has xterm-232-i486-1 installed. I see xterm-241-i486-1slack12.1 in repo, and it lists libxcb >= 1.1-i586-1vl60 as a dep, whereas only 1.0-i486-2 is available.

If you boot to TUI, use vxwmset to choose icewm, will startx bring it up then?

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2296
Re: Adding Icewm
« Reply #2 on: April 24, 2009, 09:55:16 am »
I will check the dependencies of xterm-241-i486-1slack12.1 as soon as I get home.
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: Adding Icewm
« Reply #3 on: April 24, 2009, 11:21:35 am »
No it doesn't unfortunately... it brings up Xfce!