VectorLinux
April 16, 2014, 02:18:41 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [Solved] Can't install any printer in KDE/SOHO  (Read 2668 times)
LanceHaverkamp
Member
*
Posts: 41


« on: April 25, 2009, 07:53:35 am »

I've used KDE for years (debian, mandrake, mepis, kubuntu), installed printers a hundred times, I've never seen this error before:

Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: localhost: read failed (14).

I'm getting this after the KDE Peripherals > Printers dialog box opens.

Apparently CUPS is not getting launched at boot (?) and rebooting doesn't help.  How do I fix this?  Is this happening to everyone?


P.S.  It doesn't mater if I'm user or Admin, I get the same error either way.


Lance
« Last Edit: April 25, 2009, 11:13:54 am by LanceHaverkamp » Logged
LanceHaverkamp
Member
*
Posts: 41


« Reply #1 on: April 25, 2009, 09:49:29 am »

I'm no authority, but I think the CUPS script in SOHO is not correct for KDE.  I think it's running but not in a way KDE can access it.

To start CUPS, as root from the command line:

Code:
cd /etc/rc.d
chmod +x rc.cups
./rc.cups start

This gets CUPS running properly, but does not fix the problem that is not running properly at boot!
So with this a user is required to start CUPS from the command line each time to computer is started.

Read more: http://wiki.linuxquestions.org/wiki/Slackware-FAQ#Q.29_How_do_I_add_my_printer.2F_enabling_printing.2F_etc.3F

Who knows how to fix this init script?
Logged
newt
Vectorian
****
Posts: 1132



« Reply #2 on: April 25, 2009, 09:51:58 am »

Please check VASM/Services for your run/init level and see if the CUPS service is selected to start at boot. It should be able to be dealt with there.

HTH!
Logged
LanceHaverkamp
Member
*
Posts: 41


« Reply #3 on: April 25, 2009, 11:13:33 am »

Hmmmm,

Having not seen VASM/Services on KDE/SOHO, I carefully read all the menu entries.  I found "Vector Control Center" which, it turns-out, is VASM/Services.  With some digging around into this tool I'd never seen before, I did find what you were talking about.  Yes, that solved the problem! 
I would consider not having CUPS launch by default a bug--especially on a release you are pitching as "Small Office/Home Office."  On an office desktop, they're going to expect the printer to work out-of-the-box.

Thank you so much for your help!

Lance
Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #4 on: April 25, 2009, 11:25:36 am »

I would consider not having CUPS launch by default a bug--especially on a release you are pitching as "Small Office/Home Office."  On an office desktop, they're going to expect the printer to work out-of-the-box.

Last time I installed 5.9 SOHO CUPS was an active service. Printers just don't tend to work out of the box under any OS until a printer driver is installed.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
LanceHaverkamp
Member
*
Posts: 41


« Reply #5 on: April 25, 2009, 11:37:15 am »

Sure, you have to install a driver, but I can't remember ever seeing a distro where CUPS was off by default, and didn't at least offer turn it on by default during installation.  If it's supposed to be on by default that's great...I have no idea why it didn't work that way here.  I selected a graphic desktop installation, but unchecked koffice, as I knew I was going to install OpenOffice.  Don't know if that would have any bearing...it shouldn't.

Thanks again all!

Lance




Logged
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #6 on: April 25, 2009, 01:49:11 pm »

I would turn all the services off and let the users decide what to use. Its more efficient than turning everything on. I dont have a printer, I dont share files with Windows systems or through nfs. Sshd on the other hand, is imprescindible for me. So all the users have to have sshd running just because I need it? ummm. It makes a lot of sense to me to let the users use vasm and tweak the system to their liking.

Just my 0.02
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #7 on: April 25, 2009, 02:59:37 pm »

One reason VectorLinux is so fast is that very few services are on by default. It's up to the user to select what services to run at startup. This may not suit newbies who want every conceivable thing working out of the box, but VectorLinux isn't geared to users who aren't willing to get their hands slightly dirty.

There can be confusion because expected services and some hardware initialization are off, but that's the tradeoff for a speedy system. You turn on what you want, turn off what you don't. For example, parallel port initialization is off by default. So it's not unusual for people to post about inability to get their printer working when the reason is that the parallel port isn't active. Once they turn on the parallel port in VASM, the printer comes alive.

Should it be on by default? I don't think so. Parallel port printers are becoming uncommon. I haven't had one for years. So why should I enable a parallel port I never use? As for services, I don't use most of them listed in VASM. No bluetooth, no Linux firewall, no inetd, no Samba, no ssh, and so on. But I do need portmap and cups. I need wicd on one computer. I'd rather turn on what I need than have everything on and have to turn it off.

In my opinion, the first thing a user should do when running VL for the first time is to open VASM and go through all the settings. I think VL needs to include more information suggesting what users should do to complete setting up their system the way they like it. Of course, the problem then is getting people to read it. :-(
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
LanceHaverkamp
Member
*
Posts: 41


« Reply #8 on: April 25, 2009, 05:31:48 pm »

Quote
I think VL needs to include more information suggesting what users should do to complete setting up their system the way they like it. Of course, the problem then is getting people to read it. :-(
Absolutely!  If, like me, you're coming from another distro(s) where all these things are turned-on, new users quickly assume something's broken.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!