VectorLinux
September 21, 2014, 07:49:23 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: LyX installed but doesn't run  (Read 1786 times)
LanceHaverkamp
Member
*
Posts: 41


« on: April 25, 2009, 06:56:53 pm »

LyX version 1.6.1-i586-1vl59

Installed in KDE/SOHO but doesn't run.  The command line reports:

$ lyx
lyx: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

There is nothing in the repos called "libQtGui"

Thanks,

Lance
Logged
newt
Vectorian
****
Posts: 1132



« Reply #1 on: April 25, 2009, 11:25:54 pm »

It's a TOTAL guess, but I'm guessing that it's referring to missing Qt 4.x.  I'm pretty sure the 5.9 series came stock with Qt 3.x, however Qt 4.x should be available via the repo.  It should not be installed as an upgrade to 3, but rather alongside of 3.x.  In other words, they should both be able to (and need to) coexist.

However, I've read your other post "killing me with the problems" and expect that a solution is probably not overly important for you.  Sorry for the troubles you've been experiencing.  It seems that your usage of the system is somehow different than most such that you're able to identify issues that may not have been observed before.  It doesn't mean much to your situation at-hand but it would be great to get your feedback when VL 6 SOHO goes into beta or RC testing.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3257


-- Just being myself --


« Reply #2 on: April 26, 2009, 01:40:31 am »

Is the Qt4 packages still in the testing repo (just a wild guess)? Pls try to install the Qt4 package from gslapt/slapt-get manually.

BTW, did you enable the testing repo in gslapt/slapt-get?
Logged
LanceHaverkamp
Member
*
Posts: 41


« Reply #3 on: April 26, 2009, 07:56:15 am »

Quote
it would be great to get your feedback when VL 6 SOHO goes into beta or RC testing.

Of course I'm always happy to help any way I can.  You folks do have a really nice stable project going.  As you said, for some reason, we're using very different packages.  Some of that might be as simple as xfce vs kde.  xfce people tend to use gtk programs, I tend to use all those things with a K in the name.Wink   
Your user base may simply not use those very much.

Given:
  • how bad kubuntu can get (a few releases are good, many are awful)
  • how slow debian release schedules are
  • Suse is in bed with M$

You really have an opportunity to "own" the KDE marketplace, if you can get enough testers to make sure everything works.


Logged
LanceHaverkamp
Member
*
Posts: 41


« Reply #4 on: April 26, 2009, 08:17:43 am »

Quote
I package LyX for VL6. Pls let me know what dependencies is missing? What is the error message?

Is the Qt4 packages still in the testing repo (just a wild guess)? Pls try to install the Qt4 package from gslapt/slapt-get manually.

BTW, did you enable the testing repo in gslapt/slapt-get?

I just checked, QT4 is installed in this KDE/SOHO 5.9 system.  But I'm still getting the exact same error from LyX:
lyx: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

Is it possible that libQtGui.so.4 is not the same thing as QT4?  Or is it more likely that the upstream QT4 is broken?
I'm afraid I have no idea. Undecided
Logged
hata_ph
Packager
Vectorian
****
Posts: 3257


-- Just being myself --


« Reply #5 on: April 26, 2009, 08:29:44 am »

Try this for your Lyx problem......

http://forum.vectorlinux.com/index.php?topic=8045.0
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!