VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Fan control in VextorLinux 6.0 Light  (Read 3908 times)

_HG_

  • Member
  • *
  • Posts: 23
    • www.HEATHKIT.nu
Fan control in VextorLinux 6.0 Light
« on: May 05, 2009, 01:27:18 am »

I am running VectorLinux 6.0 Light on an ASUS L-7200. A ten year old laptop. In general, it works very well.
The computer goes very hot, though. Especially when using it at the same time as charging the battery.
The cooling fan never starts. Is there a way to start it ?

/ _HG_
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Fan control in VextorLinux 6.0 Light
« Reply #1 on: May 05, 2009, 04:56:33 pm »

When you installed did you enable the ACPI service? If not, make sure it is set  to run at boot using Menu,  System, Vasm, (password), Service, HWSet, and enable the ACPI box.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

_HG_

  • Member
  • *
  • Posts: 23
    • www.HEATHKIT.nu
Re: Fan control in VextorLinux 6.0 Light
« Reply #2 on: May 07, 2009, 05:53:33 am »

Everything is enabled, so it must be something else.

/ _HG_
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Fan control in VextorLinux 6.0 Light
« Reply #3 on: May 07, 2009, 10:18:52 am »

Do you have ACPI enabled in your BIOS then?
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

_HG_

  • Member
  • *
  • Posts: 23
    • www.HEATHKIT.nu
Re: Fan control in VextorLinux 6.0 Light
« Reply #4 on: May 08, 2009, 10:36:16 pm »

It is not possible to disable it in the BIOS, so it is enabled.
Originally, when the computer was new, it had Win98SE as its OS.
Later, when Slackware 10.2 was released I installed that instead.
After a couple of years the battery was was worn out and
I can't remember if the fan control worked with Slackware 10.2.
Now I have a new battery and bringing the old computer back
to life again running VectorLinux Light.

/ _HG_
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Fan control in VextorLinux 6.0 Light
« Reply #5 on: May 09, 2009, 04:54:43 am »

Open a terminal, log in as root and type:

lsmod fan

then

lsmod thermal

If the fan works then nothing else is needed. It  the laptop is not cooling.
Then you should be able to look in /proc/acpi/THRM/ and find some settings that
you could try adjusting.

HTH

Bigpaws
Logged

_HG_

  • Member
  • *
  • Posts: 23
    • www.HEATHKIT.nu
Re: Fan control in VextorLinux 6.0 Light
« Reply #6 on: May 09, 2009, 08:52:47 am »

I have now made the lsmod fan and lsmod thermal commands.
In /proc/acpi/fan/FAN/ there is a file named state that is empty.
And so is all other files in the /proc/acpi/ sub directories.

The sub directories listed are these:
 /ac_adapter/
 /battery/
 /button/
 /embedded_controller/
 /fan/
 /power_resource/
 /processor/
 /thermal_zone/

and these files:
 dsdt
 event
 fadt
 info
 sleep
 wakeup

And as I mentioned, they are all empty (0 bytes).

/ _HG_
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Fan control in VextorLinux 6.0 Light
« Reply #7 on: May 09, 2009, 10:51:53 am »

Log into a terminal and su to root.

Now type

cat /proc/acpi/thermal_zone/THRM/temperator

See if there is output. These files are constantly changing due to reading from
the system.

Bigpaws
Logged

_HG_

  • Member
  • *
  • Posts: 23
    • www.HEATHKIT.nu
Re: Fan control in VextorLinux 6.0 Light
« Reply #8 on: May 09, 2009, 11:08:06 am »

Yes, there is an output.

It says 47 C

/ _HG_
Logged