VectorLinux
September 02, 2014, 08:33:51 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: keyboard allways goes back to default US  (Read 2690 times)
bruno
Member
*
Posts: 19


« on: May 07, 2009, 01:17:45 am »

I have installed 6.0 standard Gold, with text installer, but the keyboard always goes back to default US keyboard. I have a Belgian keyboard. In the installation on two different occasions I select the Belgian, but it always changes back. I use VASM, to change to Belgian again, but if I type in the box below to test the new setting, it's still US ...Huh
Logged
no2thesame
Packager
Vectorite
****
Posts: 136


« Reply #1 on: May 07, 2009, 03:51:41 am »

I think this may be a bug in VASM.

Try my solution from here:
http://forum.vectorlinux.com/index.php?topic=9392.0
Logged
bruno
Member
*
Posts: 19


« Reply #2 on: May 07, 2009, 06:04:34 am »

But the Belgian keyboard is very different from the US, German or Polish; we have azerty, a little like the French..
Logged
no2thesame
Packager
Vectorite
****
Posts: 136


« Reply #3 on: May 07, 2009, 06:09:18 am »

The fix will still work.
Logged
no2thesame
Packager
Vectorite
****
Posts: 136


« Reply #4 on: May 07, 2009, 07:56:12 am »

I should explain myself, sorry to be so terse, Bruno.
This change is simply doing what VASMCC should do. It will work for any keyboard on the VASM list under Hardware > Keyboard Map Selection.
To get your keyboard up you will have edit the file /etc/X11/xorg.conf as root. I suspect this will be difficult if you don't have access to a US-layout keyboard.

I don't know how familiar you are with the console but it goes like this:
Open the terminal or console
Type: su
(put in your root password)
Then copy and paste the following line (copy normally but paste at the command line with Shift+Ctrl+V to minimise your typing)

medit /etc/X11/xorg.conf

Once the editor opens search down until you come to the line in the Keyboard section:

Option     "XkbLayout"     "us"

change it to

Option     "XkbLayout"     "be"

(just change those two letters)
Save the file and reboot for the settings to take effect.
Your keyboard will have the Belgian layout when you login.
I notice there are two types of Belgian keyboard so maybe, if it isn't right the first time, you will need repeat the process and make the line look like:

Option     "XkbLayout"     "be2"

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!