Please support VectorLinux!

Author Topic: 090512 ruby-1.8.6_p368 [VL6.0]  (Read 599 times)

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
090512 ruby-1.8.6_p368 [VL6.0]
« on: May 12, 2009, 02:47:02 am »
rbistolfi has packaged ruby for VL 6.0.

Package: ruby-1.8.6_p368-i586-3vl60.tlz
MD5: f5fb54ef02eee5beac18827bda5d305a
Package Size: 2526 K
Installed Size: 24690 K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/dev/ruby

Code: [Select]
ruby: ruby (Interpreted object-oriented scripting language)
ruby:
ruby: Ruby is an interpreted scripting language for quick and easy
ruby: object-oriented programming.  It has many features to process text
ruby: files and to do system management tasks (as in Perl).  It is simple,
ruby: straight-forward, and extensible.
ruby:
ruby: Visit the Ruby project online at http://www.ruby-lang.org/
ruby:
ruby:
ruby:

This is a security fix
    http://www.ruby-lang.org/en/news/2008/08/23/dos-vulnerability-in-rexml/
This ruby package also fixes an issue reported by aixuser01 here:
    http://forum.vectorlinux.com/index.php?topic=9378.0
rubygems has been added to the package for easy installation of ruby libraries.

After testing this package please stop back here and let us know how it works for you.