Author Topic: max_cstate: No such file of directory  (Read 4831 times)

gacl

  • Vectorite
  • ***
  • Posts: 218
max_cstate: No such file of directory
« on: March 29, 2009, 01:12:50 pm »
Hey, guys, the new Vector looks awesome. Good job!

I have this question: How can i set the max_cstate?

I used to do echo $1 > /sys/module/processor/parameters/max_cstate before but now it gives me No such file or directory.

Thanks.

Gus
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: max_cstate: No such file of directory
« Reply #1 on: March 29, 2009, 03:36:19 pm »
Are you doing that as root?
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #2 on: March 29, 2009, 06:05:34 pm »
Quote
Are you doing that as root?

Yes. And the max_cstate file doesn't exist either.
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #3 on: March 29, 2009, 06:26:56 pm »
I looked at /proc/acpi/processor/CPU0/power and active state is set to C0. With 5.9 it was usually set to something and there would be an asterisk next to the corresponding state at the bottom.
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #4 on: March 29, 2009, 07:42:03 pm »
I just tested the system with 5.9 Live and it works fine. Active state reports C4 (and it gets the asterisk in the list) and i can freely toggle the states with echo (Minus the number sign. My mistake).

So what's different? The kernel? Oh, no.
« Last Edit: March 29, 2009, 07:43:45 pm by gacl »
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #5 on: March 29, 2009, 08:36:18 pm »
I found something else:

http://74.125.93.104/search?q=cache:V0FPPWKNfWQJ:lkml.org/lkml/2007/11/30/281+%22max_cstate%22+deprecated&cd=6&hl=en&ct=clnk&gl=us

If i'm not mistaken what the post says is that some old stuff, including max_cstate, is being replaced. But the post doesn't mention how can the C-states be set now. Anybody knows?


Edit: This search explains better the problem (kernel bug), and provides a temporary solution which i'm trying to understand. The latest version of the kernel seems to be addressing the issue. . . ?
« Last Edit: May 27, 2009, 03:11:51 pm by gacl »
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #6 on: May 29, 2009, 09:31:24 am »
I tried adding processor max_cstate=2 and processor max_cstate=1 to /etc/modprobe.conf but it did nothing. I tried rebooting.

Some people report having luck with processor.max_cstate=2 as a "boot option" or "kernel parameter". Does anybody have any idea of what are they talking about?

Gus
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: max_cstate: No such file of directory
« Reply #7 on: May 29, 2009, 07:51:34 pm »
The "boot options" or "kernel parameter" (maybe both) can be set up by running vliloconf (as root). The last question it asks you is something about setting one or both of those options.
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

gacl

  • Vectorite
  • ***
  • Posts: 218
Re: max_cstate: No such file of directory
« Reply #8 on: May 30, 2009, 10:21:50 am »
Thanks, Daniel, that was what i was looking for. Finally i can have some peace and quiet. *takes earplugs off*
“Our very lives depend on the ethics of strangers, and most of us are always strangers to other people.” -- Bill Moyers