VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: SOLVED:ifconfig networking  (Read 2853 times)

ghartl1

  • Vectorite
  • ***
  • Posts: 379
SOLVED:ifconfig networking
« on: June 06, 2009, 06:08:33 am »

hi,

i use soho 5.9.1 and want to connect to an ap via wireless...

my problem is that ifconfig shows only the lo interface

with ifconfig -a all interfaces appears....

which file i should edit , so the interfaces are all active...#

second question...for wireless

i will use wifi-radar

is it necessary to edit files in /etc/rc.d/ too? (ec.inet1.conf...rc.wireless.conf..rc.wireless...)

greets günter
« Last Edit: June 06, 2009, 03:53:52 pm by ghartl1 »
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: ifconfig networking
« Reply #1 on: June 06, 2009, 09:59:38 am »

Have you run netconf in vasm yet?
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

ghartl1

  • Vectorite
  • ***
  • Posts: 379
Re: ifconfig networking
« Reply #2 on: June 06, 2009, 03:53:29 pm »

yes i ran vasm..network..wireless too

anyway..meanwhile the problem is fixed
i fiddeld for about 5 hours with wifi-radar to fix it...to no avail
btw: no luck with vwifi (what use wifi-radr in the background too)
vasm with netconfig failed too..

so my last resort was wicd...installed it (actually i had a slackware package from 12.2 on my stick.
installed it,,did 3 more clicks and i was online..what should i say...wasted 5 hours

wireless was with wep encryption..wifi-radar failed even with no encryption (never got an ip adress..ap was the dhcp server too)
maybe the software wasnt compatible with the arris -modem??  who cares now..

wicd was there in the nick of time..easy to configure (to be honest..wifi-radar is also easy to configure)but only wicd worked..and still works (never tried networkmanager, knetworkmanager...)

the solution isnt really traceable for me...anyway...now all is fine

except: does anybody know, how i can configure wicd, so it starts on every bootup?
in the meantime i start wicd ..enter root password and wicd emerges with the chosen wireless network already connected...so far so good

what i want: the box boots up and the internetconnection should establish automatically via wicd without interaction from the user...

any ideas?

although i struggled today with the internet-issue,i am still a dye hard slackware(respective vector-affiliate) i just love the speed, simplicity and the well choosen apps in vector.....good work...and even this windows -user loved the clean kde-desktop and apps (gftp, krename,home-folder,firefox, speed of the internet....)

so, i will stay with vector for sure..only for learning purposes i sometimes use slackware....

see you...

greets günter
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: SOLVED:ifconfig networking
« Reply #3 on: June 06, 2009, 04:28:59 pm »

To autostart Wicd, copy its .desktop file to ~/.kde/Autostart   The .desktop file is probably in /usr/share/applications/   (you can also get to Autostart by opening Konqueror and clicking the "Go" menu at the top. There will be an entry labeled Autostart.) I haven't used Wicd but I think there should be an option to start the connection automatically.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

ghartl1

  • Vectorite
  • ***
  • Posts: 379
Re: SOLVED:ifconfig networking
« Reply #4 on: June 06, 2009, 05:07:17 pm »

the option to start the connection in wicd automatically, already works...to start wicd automatically was my intention..

i will try with the autostart thing in kde

thanks meanwhile

greets günter
Logged

ghartl1

  • Vectorite
  • ***
  • Posts: 379
Re: SOLVED:ifconfig networking
« Reply #5 on: June 08, 2009, 04:27:13 am »

ääähh..the problem is that wicw need root access too

how can i manage it to start automatically
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: SOLVED:ifconfig networking
« Reply #6 on: June 08, 2009, 08:39:47 am »

only the wicd daemon needs root access. You can enable the service in vasm iirc, or add

/usr/sbin/wicd

to your /etc/rc.d/rc.local file. For starting the client (the systray icon) you need to add the wicd-client command to the autostarted applications.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!