VectorLinux
October 26, 2014, 01:07:05 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: VL 6.0 LightEd - keys-shortcuts  (Read 1652 times)
gomez
Member
*
Posts: 7


« on: June 06, 2009, 12:10:36 pm »

I've VL 6.0 LightEd new installed.
In ~/.icewm/keys the terminal is mapped to "Alt+Ctrl+t". But if I press "Alt+Ctrl+t" a text-editor is opening?
Are there additional key-mappings elsewhere? Any ideas?
Thanks for any advice!
Gomez

« Last Edit: June 06, 2009, 01:48:55 pm by gomez » Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: June 06, 2009, 02:28:40 pm »

I think you can get the terminal by pressing f4.  Not sure about the keymapping though, only just started using light, for packaging purposes.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #2 on: June 07, 2009, 06:24:40 am »

Try Win+s for a shell, Win+a for root (administrator).
Logged
gomez
Member
*
Posts: 7


« Reply #3 on: June 07, 2009, 04:25:09 pm »

Hi, thanks for your replies.
Unfortunately no keys worked.
But I found why leafpad is opening.
In ~/.icewm/keys there is also the entry
Code:
key "Super+t" leafpad
So I commented this line and the
Code:
key "Alt+Ctrl+t" xterm
worked as expected.
But I still don't understand why the "Super" key overwrite the "Alt-Ctrl" key-combination.
Has somebody else this experience in Icewm, or is this a problem of my installation or notebook?
 
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #4 on: June 07, 2009, 09:05:51 pm »

The keys in Light are set up the way I like them.  Wink

Realizing that's not necessarily what everyone wants, instructions leading to editing the keys file was included in the welcome document that pops up on first run (or launched from desktop icon).
Logged
gomez
Member
*
Posts: 7


« Reply #5 on: June 08, 2009, 12:22:01 pm »

Quote from: nightflier
... instructions leading to editing the keys file was included in the welcome document that pops up on first run (or launched from desktop icon).
I read this document, but it doesn't work like expected.
If your Super-key doesn't overlay the Alt+Ctrl Keys at your installation then its a local computer problem I think I have.
Fortunately I've found an workaround (commented Super-keys) in the keys - file.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #6 on: June 08, 2009, 06:35:43 pm »

Yeah, looks like mixing in the Super key may lead to some unexpected results. IceWM has a lot of options and features, more than I use on a regular basis. Glad you got it working the way you want it.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!