VectorLinux
April 17, 2014, 02:02:10 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: VIM - MiddleMouseButton doesn't work - VL6.0light/IceWM  (Read 2204 times)
gomez
Member
*
Posts: 7


« on: June 12, 2009, 02:21:02 am »

I can't use the middle mouse button in VIM to copy and paste. If I open a Document in vim (7.1), mark text with the mouse and want to paste it to a terminal - it doesn't work. Within terminals it works, so I think the xorg.conf is ok. It's the same behaviour in  icewm, jvm and mwm.
I have another laptop with debian and icewm where I can copy&paste with the middle mouse button within vim. I've tried it with the same .vimrc, but unfortunately without success.

Has somebody any idea what I can do? I got used on this feature, so I would be very happy if somebody can help me!
« Last Edit: June 12, 2009, 02:23:22 am by gomez » Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #1 on: June 12, 2009, 03:08:14 am »

hi gomez,

IIRC default vim is compiled without the +clipboard option .

I think we have a more complete vim in the repos.

If it's not there, you can make a request in the apropiate section and silently wait.... Smiley

I compile my own vim in all my boxes, because I want more options than default ones (--enable-perlinterp --with-features=huge )

HTH
Logged

rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #2 on: June 12, 2009, 07:06:36 am »

Right, the package in the repos enters visual mode with middle button. I have been working in a new vim build, there is a new release (7.2). If there is consensus about the clipboard feature I will gladly add it.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
kidd
Packager
Vectorian
****
Posts: 682


« Reply #3 on: June 12, 2009, 12:25:27 pm »

--with-features=huge enables the clipboard thing, so your package might already have it.
Logged

gomez
Member
*
Posts: 7


« Reply #4 on: June 13, 2009, 11:15:27 am »

Hi ribistolfi, Hi kidd,

Thanks for the answers!
Unfortunately I can't find a more complete vim (my Version: 7.1.285-i486-1) in the repos. Do I have add another repos?

Quote from: rbistolfi
...the package in the repos enters visual mode with middle button
Is it possible that libraries are missing in my installation to use these feature within vim?

Quote from: kidd
If it's not there, you can make a request in the apropiate section...
Do you mean within the forum or somewhere else?

If I have to compile vim myself I think I'll need your help again!
Thanks,
gomez
« Last Edit: June 13, 2009, 01:55:07 pm by gomez » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #5 on: June 13, 2009, 04:12:54 pm »

Unfortunately I can't find a more complete vim (my Version: 7.1.285-i486-1) in the repos. Do I have add another repos?

You could try the vim Slackware pacakges at http://www.linuxpackages.net/search_view.php?by=name&name=vim&ver=

You probably will have to then add your own menu entry however, as most Slack pkgs do not have an included .desktop file.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
gomez
Member
*
Posts: 7


« Reply #6 on: June 14, 2009, 03:25:47 am »

You could try the vim Slackware pacakges at http://www.linuxpackages.net/search_view.php?by=name&name=vim&ver=
I've tried the suggested Slackware package, but without success. It shows the same behaviour.

Then I tried to compile vim myself - and it works Kiss

Here what I did (I am a newbie - please correct me if something is wrong or strange Wink)
1. Deinstalled the package-vim with gslapt
2. Download vim from  http://www.vim.org/download.php#unix vim-7.2.tar.bz2
3. $ cd <downloaddirectory>
4. $ cd src
5. In the Makefile there I enabled
Code:
CONF_OPT_FEAT = --with-features=huge
like
I compile my own vim in all my boxes, because I want more options than default ones (--enable-perlinterp --with-features=huge )
explained (Thank you!).
I also disabled the GUI in the Makefile
Code:
CONF_OPT_GUI = --disable-gui
6. $ cd ..
7. Then compile, link,  ... etc , like its explained in src/INSTALL with:
$ make
8. Then install in /usr/local with
$ sudo make install

Then I removed the dead link vi -> vim in /usr/bin and created a new link in /usr/local/bin/ vi -> vim.

I still don't understand why the vim-packages doesn't work.

If I want other vim compiling options, is it sufficient to run make and make install again or do I have to uninstall it first?

« Last Edit: June 14, 2009, 03:28:48 am by gomez » Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #7 on: June 18, 2009, 03:25:45 pm »

I use to uninstall first and then configure with the desired options (I use a clean untargz'ed source dir every time, just in case)
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!