VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL 5.9 + Atheros AR5006EG wireless adapter  (Read 4961 times)

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
VL 5.9 + Atheros AR5006EG wireless adapter
« on: June 28, 2009, 10:40:57 pm »

lspci says the adapters of my acer aspire one are:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adpater (rev ff)

In GUI mode, when I go to VASM -> Network -> Wireless, "probing modules" says no card is found.

In TUI mode, when I go to VASM -> HARDWARE -> HWCONF, I am asked to set up the mouse and when I hit OK it says no modem was found and goes back to HARDWARE.

I have googled for AR50006EG + modules as explained in the How To but I am new to linux and don't even know what I am supposed to find. All I could get was madwifi 0.9.4.tar.gz
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #1 on: June 29, 2009, 12:15:49 am »

what is the output of lsmod?
Logged

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #2 on: June 29, 2009, 05:27:08 am »

Code: [Select]
root:# lsmod
Module                  Size  Used by
acpi_cpufreq            7880  1
freq_table              4768  1 acpi_cpufreq
lp                     10888  0
parport_pc             37092  0
parport                32072  2 lp,parport_pc
snd_seq_dummy           3716  0
snd_seq_oss            32128  0
snd_seq_midi_event      7168  1 snd_seq_oss
snd_seq                48720  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7692  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            38048  0
snd_mixer_oss          15232  1 snd_pcm_oss
ath_pci                89504  0
snd_hda_intel         283040  0
wlan                  192964  1 ath_pci
iTCO_wdt                9640  0
ath_hal               190672  1 ath_pci
r8169                  26632  0
snd_pcm                69764  2 snd_pcm_oss,snd_hda_intel
i2c_i801                8592  0
i2c_core               20992  1 i2c_i801
snd_timer              19972  2 snd_seq,snd_pcm
snd_page_alloc          8712  2 snd_hda_intel,snd_pcm
serio_raw               6276  0
snd_hwdep               7812  1 snd_hda_intel
shpchp                 30228  0
pci_hotplug            28616  1 shpchp
snd                    45796  10 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore               7008  1 snd
evdev                   8704  5
joydev                  9152  0
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #3 on: June 29, 2009, 07:07:28 am »

what is the output of ifconfig -a and iwconfig?
Logged

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #4 on: June 29, 2009, 07:33:59 am »

Code: [Select]
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:23:8B:28:9C:9A
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:2494453365 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Code: [Select]
root:# iwconfig
lo        no wireless extensions
eth0      no wireless extensions.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #5 on: June 29, 2009, 07:48:57 am »

Try this....it suggest you use ndiswrapper.....

http://alumni.imsa.edu/~spillner/asus_a7k.html

PS: VL6 is available. Why not you try it instead of VL5.9? :P
Logged

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #6 on: June 29, 2009, 08:15:13 am »

I tried to use the "would you like to try ndiswrapper" option from GUI VASM but still it says "no card found" after I point VASM to the .inf file of the driver.

It's a mini-laptop with no CD-ROM drive, I need to get a SCSI to USB adapter. I'll upgrade if I can find one.

thanks for your time.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #7 on: June 29, 2009, 08:18:28 am »

Do you have a USB pendrive? Download the XP driver via the USB drive and use ndiswrapper to install the driver.

For laptop/PC that don't have CD-ROM, you can try use UNetbootin to install OS using USB pendrive.

http://unetbootin.sourceforge.net/
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #8 on: June 29, 2009, 12:06:35 pm »

Your Atheros chipset is natively supported by the ath5000 driver in recent Linux kernels.  You don't need ndiswrapper and you don't need madwifi.  What you do need is a newer version of Vector Linux, specifically 6.0, which has this support built in.

If you insist on running an 18 month old version of VL then you already have the link that explains how to build and install madwifi.  Tell us specifically what you don't understand and we can explain it to you.  I think in your case running a more up to date version of VL would be just plain easier.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #9 on: June 29, 2009, 06:32:06 pm »

If you insist on running an 18 month old version of VL

I don't insist,

It's a mini-laptop with no CD-ROM drive

Anyway I got someone to lend me a SCSI to USB adapter, so, yeap, I am upgrading.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #10 on: June 29, 2009, 06:45:24 pm »

Hope the new VL6 can solve your problem. :)
Logged

AdriansonCrusoe

  • Member
  • *
  • Posts: 11
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #11 on: July 03, 2009, 08:33:11 pm »

Hope the new VL6 can solve your problem. :)

It did, it seems.
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL 5.9 + Atheros AR5006EG wireless adapter
« Reply #12 on: July 26, 2009, 06:20:20 pm »

Glad to hear it.  Hardware support in Linux is constantly improving so running a recent version is always a good idea.

Please mark the title of this thread [SOLVED] so folks know that you're not still looking for help.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1