VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 6.0 Deluxe CD2 fails  (Read 2738 times)

Stevo

  • Member
  • *
  • Posts: 19
    • The Rolex Forums
6.0 Deluxe CD2 fails
« on: January 07, 2010, 05:11:03 pm »

I've tried many different command lines but CD 2 will just not load into Gslapt.

I've tried:
file:///media/cdrom0/packages/
file:///media/cdrom/packages/
file:///media/vectordlxcd2/packages/
file:///media/vectordlxcd20/packages/
and a bunch of others.

It seems like Gslapt will just not even read or attempt to read from the cdrom.

The error message says: "The package source failed or is not available."

When I go to file manager, all the folders and files are on the CD as one would expect.

Any help would be appreciated.

Thanks
« Last Edit: January 07, 2010, 06:11:24 pm by Stevo »
Logged

Stevo

  • Member
  • *
  • Posts: 19
    • The Rolex Forums
Re: 6.0 Deluxe CD2 fails
« Reply #1 on: January 07, 2010, 09:02:13 pm »

I checked the md5 checksum on the iso file download and it confirms it is all good there.

surely the problem must be with the commandline syntax.

Should the CD be unmounted when it is being run in Gslapt?
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: 6.0 Deluxe CD2 fails
« Reply #2 on: January 08, 2010, 08:16:51 am »

I think the cdrom should be mounted. In Gslapt, use whatever path you use to access the content of the cd starting from the root directory. Maybe something like /mnt/cdrom
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

Stevo

  • Member
  • *
  • Posts: 19
    • The Rolex Forums
Re: 6.0 Deluxe CD2 fails
« Reply #3 on: January 11, 2010, 04:38:10 am »

/mnt/cdrom....I've tried that and it doesn't work.

The CD is working properly, but does it need to be given admin access or something??

This is weird, I've tried so many combinations and I can't get the CD to read from Gslapt.
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: 6.0 Deluxe CD2 fails
« Reply #4 on: January 11, 2010, 06:05:07 am »

Can you browse to the cd in your file manager and look at the packages that way? If you can do this, you cd is mounted and you can try using Gslapt again.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: 6.0 Deluxe CD2 fails
« Reply #5 on: January 11, 2010, 06:08:13 pm »

I don't know if this will help and I don't remember if it worked with Gslapt when I installed VL6 Standard Deluxe many months ago. But this is what I found in my /etc/slapt-get/slapt-getrc file:
#DISABLED=file:///media/cdrom0/packages/
#DISABLED=file:///mnt/cdrom/packages/

My guess is that you'd change that to
SOURCE=file:///media/cdrom0/packages

Put your CD in the drive and mount it. See if you get a directory in /media/cdrom0. If it automounts to /mnt/cdrom, unmount it as root and mount it at /media/cdrom0. Then run Gslapt and see if this source is listed in Edit menu, Preferences, Sources. Make sure it is checked. You have to run Update in Gslapt. If this doesn't work, try again with the CD in the drive but unmounted.

If no luck, do the same steps again but this time make the change in /etc/slapt-get/slapt-getrc to SOURCE=file:///mnt/cdrom/packages

Put a # in front of SOURCE=file:///media/cdrom0/packages to comment it out so it won't appear in the Sources list in Gslapt. run Gslapt as above, Update, and see if you have any luck this time.

I don't know enough about this to know whether my suggestions will do any good. I do remember that I had a hard time getting the right syntax for adding the CD to the Sources list so that it actually worked.

Let us know if either of these helps you out.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

Stevo

  • Member
  • *
  • Posts: 19
    • The Rolex Forums
Re: 6.0 Deluxe CD2 fails
« Reply #6 on: January 17, 2010, 02:52:22 pm »

I don't seem to be getting any closer to a remedy on this one.

It's pretty frustrating that I got the Deluxe version and I can't even use it.......
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: 6.0 Deluxe CD2 fails
« Reply #7 on: January 17, 2010, 04:11:30 pm »

Can you browse the cd and see the packages as Daniel asked earlier?
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Stevo

  • Member
  • *
  • Posts: 19
    • The Rolex Forums
Re: 6.0 Deluxe CD2 fails
« Reply #8 on: January 19, 2010, 06:27:45 pm »

Yes, I can browse all the packages on the CD, I've burnt a few ISO's and so I did that properly.

The files and packages are all there on the CD.  ??? ???

Thanks
Logged