VectorLinux
April 20, 2014, 03:56:50 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Changing the window manager in Vector SOHO  (Read 2341 times)
Colonel Panic
Vectorian
****
Posts: 526


« on: June 27, 2009, 09:46:41 am »

Hi. I'm trying to use VASM to change the window manager in Vector 5.9 SOHO (which defaults to KDE), but it doesn't accept any of the options I give it; it keeps returning to KDE. Is there anything I'm doing wrong?

Any help will be appreciated.

Thanks in advance,

Colonel Panic.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: June 27, 2009, 10:27:13 am »

I have not tried this in Soho, but this worked for me when I was stuck in kde on standard.
Like you the VASM tool for the job was not working for some reason.

This is the screencast that got me out of the situation.
http://www.opensourcebistro.com/Tutorial/VL60/Trouble-Shooting/kdm-fix/kdm-fix.htm

From what I understand from MOE-Inx it is just the manual method of doing what VASM should do.
Please post back, I'm curious if it is a solution for Soho, also.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Colonel Panic
Vectorian
****
Posts: 526


« Reply #2 on: June 28, 2009, 01:43:43 am »

Thanks for your reply. Sadly not; it loaded KDE again as before. Maybe GDM isn't installed by default in SOHO?

It's not the end of the world as KDE is a perfectly decent desktop/window manager, but I'm looking to save on system resources and it uses a lot of RAM.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #3 on: June 28, 2009, 04:37:54 am »

SOHO uses KDM, which does have the option to choose session type upon login. Have you tried that?
Logged
Colonel Panic
Vectorian
****
Posts: 526


« Reply #4 on: June 28, 2009, 04:50:57 am »

Thanks for replying. Yes, it was the default. If you go to rc.d and then rc.X KDM is the one you find given as the default login manager.

For some reason though it didn't work; my login took me straight to KDE without an option being given. I only switched to VASM as a result of not having any prior options.

Anyway, I've got Fluxbox working in SOHO now, though it took a bit of manual configuration; I changed the last line of .xinitrc to "exec /usr/bin/startfluxbox".

All's well that ends well.
Logged
bigpaws
Vectorian
****
Posts: 1833


« Reply #5 on: June 28, 2009, 06:19:15 am »

There is another way.

Open a terminal and type xwmconfig
then make your pick.

Bigpaws
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!